Re: xterm, mcedit, ctrl-INS

On Wed, 12 Mar 2003, Pavel Roskin wrote:


I see that shift+arrows, shift+INS seems to be working in xterm from about
4.6.0. (in linux xterm)
But ctrl-INS already don't works as "paste".

Sorry, I mean "copy".

Unfortunately, the new code for keyboard input was unfinished in version
4.6.0.  Some sequences were hardcoded in the source, but Ctrl-Insert was
not one of them.

You can use "Learn Keys" dialog, select Insert and press Ctrl-Insert.
This would remember the sequence for Ctrl-Insert.  Insert should not be
affected unless you used Learn Keys to define it.

I tried, ctrl-INS acts as normal INS. ("o" in the top status bar, changes
when I press ctrl-INS)

Ctrl-Insert will copy selected text to the mc clipboard, like Ctrl-f, but
without questions.  It's not "paste".  To paste, use Shift-F15.

This paragraph is a bit magical for me:
-ctrl-ins doesnt works
-ctrl-f acts as a right arrow
-F15? I tried to use "learn keys" for make F15 key, but Shift-new f15
doesnt works. (I checked with F1 and Numerical Home)

Thanks for your reponse, and sorry for my beginner questions.

Veres Lajos
lveres vatera com
+36 20 438 5909

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]