Re: Just tried compiling 4.6.0 for OS X jacguar...


I also tried adding -libintl to the LIBS = entry in the make file and that didn't work.

I noticed the following as it was compiling:

rm -f libintl.a
ar cru libintl.a intl-compat.o bindtextdom.o dcgettext.o dgettext.o gettext.o finddomain.o loadmsgcat.o localealias.o textdomain.o l10nflist.o explodename.o dcigettext.o dcngettext.o dngettext.o ngettext.o plural.o plural-exp.o localcharset.o localename.o osdep.o
ranlib libintl.a
ranlib: file: libintl.a(osdep.o) has no symbols
cp ./libgnuintl.h libintl.h

Would this explain why there would be problems with libintl?

thanks for your help


On Tuesday, March 11, 2003, at 08:54 AM, Jan Pauli wrote:

Compiling was just fine but the linker didn't find some functions. Just include libintl in the makefile (search for LIBS = ... and add -lintl) and try it again.

thought i did everything right, but i'm getting the following:
ld: Undefined symbols:
make[2]: *** [mc] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
Any help is Greatly appreciated!
Mc mailing list
Mc gnome org

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]