[no subject]

Then the question is why cpio finds a truncated file.  VFS makes a local 
copy of the file, so maybe cpio is run before the local copy is ready?

The extfs filesystem opens a file with a random name and closes it.  This
way it reserves the name for the extfs script, which cannot be trusted
with creating a file safely.  Then the script (rpm in this case) writes to
that file.

After that, mc opens and closes that file again.  That's how
extfs_getlocalcopy() works.  It may be unoptimal, but it works for most of

Then the command (cpio with arguments) is put to another temporary file
and executed, and its output is fed to the viewer.

To sum up, the local copy of the cpio archive is opened and closed 4 times 
- by mc, by the "rpm" script, by mc again, and then by cpio.

One thing is clear - the error you observe is quite subtle and requires a
lot of work to understand.  If I get a chance to use Solaris, I'll try to
reproduce this problem.

On the positive side, I have fixed the viewer so that it doesn't display 
two messages about the same error.  It the script printed anything to 
stderr ("cpio: premature end of file" in your case), this output is shown, 
and the generic message ("Empty output from child filter") is 
now suppressed.

There was no reply to my last e-mail, not even in private.  That's very
characterisic for many users of Midnight Commander - as soon as there is
another way to do something (Enter vs. F3), nobody cares why the original
approach (pressing F3 on cpio archives) didn't work.

That's characteristic of people who have a life i.e. work beside
debugging useful tools. I try to help, but my company better not even
know about it... (Too late now, they're throwing me out. ;->>)

Oh, I see.  I'm sorry, my assumption was wrong.  I often deal with users
who simply want free technical support and don't care about the project at
all.  I'm glad that you are not one of them.

That's one of the reasons why some problems remain unfixed for years.

I honor your high opinion of open source development, but my experience
is often that I find bugs, find workarounds/fixes, report them (in a
friendly manner IMO), and they never get commented, let alone fixed. I
have two recent examples pending which I tried to revive yesterday, one
with the build of "mutt" on Solaris 2.6, one with the build of "file"
on any platform. No response for months! I'm glad you're different. :-)

A good bug report is important to get a reply, but hardly sufficient.  
Developers have their own priorities and their own understanding how to
spend their time more effectively.

And that, in turn, may be one of the reasons why so many bugreports for
Midnight Commander (compared to other projects) don't include its version
number - people think that nothing changes between versions after seeing
the same bugs over and over again!

I will not quote the subject of this thread here ;-) but I assume you
didn't mean me. :)

Of course not!  But we had another "case" today:

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]