Midnight Commander jibberish in X windows

Problem: When I view a binary file with the internal MC editor (F3), scrool up          
and down with PGUP and PGDOWN and then press F3 again to exit, both panels 
are full with unrecognisable characters. 
I took a screenshot:

The same problem is with the man pages. When I do man bash for example, I get 
the strange symbols again if I scrool up and down.

The problem doesn't exist if I ssh to another PC with RH 7.2 for example and 
run MC on that comp.

The strange characters appear only in places where the editor should display 
dots (characters, taht can't be displayed).

I tried to install a different version of MC, same results.
I also tried to compile it with --with-ncurses
then with a different version of glib,
no changes

Environment: The problem exists only if i view from the console in Xwindows 
mc -V
The Midnight Commander 4.1.35-A11
with mouse support on xterm.
Edition: text mode.
Virtual File System: tarfs, extfs, ftpfs, mcfs.
With builtin Editor
Using S-lang library with terminfo database
With subshell support: as default
With DUSUM command
With support for background operations


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]