mc on cygwin problems


I sent e-mail to cygwin list but no one can help me there. This is 
message (some more thoughts below):

I am trying use mc on my installation of cygwin. But I have problem with 
Polish diacritics in file names.

mc doesn't display them correctly at all and I cannot input several of 
them into command line.

The same problem exists under Linux but after downloading latest version 
from CVS and compiling with --enable-charset --enable-extcharset options 
it was solved.

I done the same. BTW - much kudos to Cygwin and mc developers. Vanilla 
mc sources from CVS compiled without big problems on Cygwin.

Minor problem was with iconv. mc couldn't find libiconv - had to install 
libiconv package in addition to libiconv2. Some naming problem? 
Shouldn't be it something like libiconv-devevl?

But there are still two problems:

- on Linux after compiling with charset options dialog for "display 
bits" changes from menu:

(*) Full 8-bits output
( ) ISO 8859-1
( ) 7 bits
[x] Full 8 bits input

to dropdown menu when I can explicitly select which encoding I want to 
use. When selecting proper encoding (in my case ISO 8859-2) all problems 
with encoding vanish. That is on Linux. On Cygwin old dialog stays.

- mc is terribly slow when starting + zsh is going into overdrive. CPU 
usage jumps to 30% and whole computer significantly slows down (and this 
doesn't stop after closing mc, to stop that I have to shell where mc was 
started). But this is not the case with Cygwin mc. Should I adjust 
compilation somehow? OK - "solved" - had to completely disable subshell.

Still more important for me is encoding problem. Maybe it can be solved 
on Cygwin level somehow? But I don't know which value should I set.

Native Polish encoding for Windows is cp1250.
But console encoding is cp852.

I should add that input of Polish diacritics in command line is OK, 
there are problems with displaying of them but applications understand 
them - eg zsh command line completion works as I should expect.

What and where should I set?


After some thinking I have another idea where problems lie:

There is suggestion that automake tools (or gcc) are lying. Configure 
command is:

./command --enable-charset --enable-extcharset --with-subshell=optional

Configure at the end reports:

Source  code location: .
Compiler: gcc -std=gnu99
Compiler flags: -g -o2 -Wall
File system: Midnight Commander Virtual File System, cpiofs, extfs, 
tarfs, ftpfs, fish
Screen library: Included S-Lang library (mcslang)
Mouse support: xterm only
X11 events support: no
With subshell support: optional
Internal editor: yes
Support for charset: yes

So support for other charsets should be included. But also subshell is 
reported as optional. I understand that means subshell for working 
should be called explicitly with `mc -U` - but even calling just `mc` 
starts subshell (and problems mentioned above). Looks like configure is 
lying. How to verify and fix that?


gcc --version: 3.4.4
autoconf --version: 2.61
automake --version: 1.10.1


Seksowne tancerki i zakochani  młodzi mężczyźni, 
oraz gangsterzy trzymający twardą ręką show biznes. 
Zobacz to na żywo:

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]