Re: VFS: tar file inside of a tar file crashes mc


Thanks for reply!

Output of "mc -V" on my current system:

GNU Midnight Commander 4.6.2-pre1
Virtual File System: tarfs, extfs, cpiofs, ftpfs, fish, undelfs
With builtin Editor
Using the ncurses library
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
With support for X11 events
Data types: char 8 int 32 long 32 void * 32 off_t 64 ecs_char 8

My current system:
Slackware 12.0 (glibc 2.5, gcc 4.1.2)
actual kernel
(but I also tried with stock kernel,
and of course I tried the mc 4.6.1 version that comes with Slackware 12.0)

I also tried (around one year ago) with Slackware 10.1 and mc 4.6.1
(the mc version included and self compiled)

And I tried KNOPPIX 5.1.1 (a live Linux system, Debian based) with
the included mc 4.6.1.

To reproduce the crash:

- create a tar file inside a tar file

echo xxx > xxx
tar cvf 1.tar xxx
tar cvf 2.tar 1.tar

- open a regular xterm and type mc to start it

- double click on "2.tar" to view its contents

- double click on the included "1.tar" to view

- and now type "cd" on mc's command line to change back to
 your home directory and leave the VFSs
 (do NOT use the mouse to click you outside of the VFSs,
 use a cd command, that is very important!)

- open "Active VFS list"

- click on "Free VFSs now" two times (important: click twice)

mc will crash instantly

Instead of opening the "Active VFS list" you can just wait until
mc frees VFSs by itself.

In the meantime I also tried with a zip file inside a zip file,
but mc did NOT crash.
It seems only tar files affected.

Please keep me informed if you were able to reproduce
the crash.


Jürgen Heinrich

Pavel Tsekov wrote:
Hello Jürgen,

Sunday, November 18, 2007, 12:42:52 AM, you wrote:

Since Midnight Commander version 4.6.1, there is a problem with VFS:

Tab into a tar file that contains another tar file and then into the
included tar file. (tar file inside tar file, or maybe VFS inside VFS)
Then leave all VFSs.

Now wait until mc frees VFSs by itself or open "Active VFS list" dialog
and hit "Free VFSs now" twice.

Midnight Commander will crash.

I've tried to reproduce the crash but without success. Can you provide
the output of "mc -V" as well as more information regarding your
environment. Are you sure that the steps above are enough to get MC
to crash - perhaps there is somthing else which must be done ?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]