Re: [PATCH] glib2.0 mini patch works with todays anoncvs


> > I didn't apply you patch for  I think your build
> > environment is wrong.  Cygwin uses some wrappers that check for
> > requirements before calling one of the versions. has this
> > line:
> no this assumption is wrong. i am author of one of the bigger gnome 2
> buildscripts around we are able to paralell install vanilla automake
> 1.4-p6 and automake 1.6.x within the same prefix. please get automake
> 1.4-p6 from and investigate into the readme and changelog
> there. please also consult this context.

Just because GNOME hackers decided to take this approach (and that's what
your links say), it doesn't make this approach is right for Midnight

If only Automake 1.6.x was supported and both 1.5 and the forthcoming
Automake 1.7 were known to be incompatible, then maybe I would use the
versioned script `automake-1.6'.  But Automake actually tries to be
backwards compatible when it's practical.

> now this is nice for the automake itself. but if it uses e.g. the 1.4
> binary then it spits out error. so it makes sense in the file
> to explicitely use the correct version.

There is no such thing as "the correct version".  CVS Automake uses
versioned name `automake-1.6c' and I don't want to discourage anybody from
trying it.

> but recently i got trapped myself by this e.g. i read in the mc
> changelog that you need at least automake 1.5. i installed automake 1.5
> specially for mc and mc refused to generate the makefiles because it
> depends on 1.6 already. so it may be interesting and for sure a good
> idea to rename it to automake-1.6 at least from a vanilla point of view.

I just tried automake 1.5 with CVS MC and it did work.  Please report such
errors.  Don't assume that nobody cares.

Version in AUTOMAKE_OPTIONS means minimal version.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]