Re: Problems with the mouse

Hi, Franco!

On Sun, 6 Jan 2002 frantz sitoverde com wrote:

> When I do an ldd to the mc executable it states that it is linked
> against, but when I run mc, the mouse does not work as
> expected (i.e. it still copies and pastes text even if I don't hold the
> shift key, and menus don't get accessed by mouse).

Two possible problems:

1) You have gpm from RedHat with a patch that disallows users to access
the mouse through libgpm.  Recomplile gpm from the sources if that's the

2) It may happen that you don't have access to /dev/misc/psaux or to 

libgpm support is tricky to enable on modern systems, so it may be dropped
in the future versions of MC if a better way of interacting with gpm will 
be found or developed.

> I started to think it is a problem of devfs, but when I run the devfsd
> daemon in order to have the symlinks of the old device names, the mouse
> in mc still does not work.

You are missing two steps between setting up devfs and checking mc:

1) make sure that gpm is running
2) make sure that the mouse cursor is moving when mc is not running.

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]