Re: Function prefixes

Behdad Esfahbod wrote:
> I got some comments on my weblog about using gl_ as function
> prefix:

... and one of the comments says that some OpenGL package really uses
"gl_" as prefix: gl_Color etc.

So I agree, the potential for confusion is too big. Let's choose a
different prefix. Thanks for having collected these comments.

> So, hereby, I suggest using "giu_" instead.  How's that?

Well, giulia is the roof project for a set of separate libraries and
programs. To stress the fact that they are _separate_ and that we don't want
a big ICU-like thing, I'd prefer to have a prefix for libglocale, a prefix
for the Unicode regex library, a prefix for the GNOME configuration panel, etc.

So I'm inclined to use "glc_" for libglocale.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]