Stock item "GO_BACK"
- From: John Emmas <john creativepost co uk>
- To: gtkmm-list gnome org
- Subject: Stock item "GO_BACK"
- Date: Wed, 04 Dec 2013 15:28:46 +0000
I'm building a gtkmm dialog which uses the following line of code to add
a button (where 'back_button' is of type Gtk::Button*):-
back_button = add_button (Stock::GO_BACK, RESPONSE_NO);
When the specified button is 'Stock::GO_BACK' the program repeatedly
crashes at run time. I've tried around 20 other values (Stock::OPEN /
Stock::CANCEL / Stock::QUIT etc) and all of them worked successfully.
It's just that one value which crashes. The only discrepancy I can see
is this (in gtkmm/stock.h):-
extern GTKMM_API const Gtk::BuiltinStockID GO_BACK; /*!<
left-to-right languages: @image html gtk-go-back-ltr.png */
compared to this, in gtkstock.h (libgtk):-
/**
* GTK_STOCK_GO_BACK:
*
* The "Back" item.
* <inlinegraphic fileref="go-previous-ltr.png"
format="PNG"></inlinegraphic>
* RTL variant
* <inlinegraphic fileref="go-previous-rtl.png"
format="PNG"></inlinegraphic>
*/
#define GTK_STOCK_GO_BACK "gtk-go-back"
Notice from the comments that gtkmm seems to think the graphic image
should be called "gtk-go-back-ltr.png" whereas gtkmm thinks it's called
"go-previous-ltr.png". I don't know if I happened to pick 20 good
examples but in all the other cases, gtkmm and gtk+ seemed to agree
about the name. Could this disagreement be causing my crash? And if so,
which name is the right one?
John
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]