Re: error while loading shared libraries:

hello, Gavin:

I ran the command "sudo ldconfig" and then compiled and ran the application and it worked, thank you ...
thanks for the tip...

2011/6/1 Gavin Lambert <gavin lambert compacsort com>
Quoth Rodrigo Nunes:
> gtkmm3.0 installed the library on my computer, the program compiles but at

> run-time shows the following error:
> error while loading shared libraries: can not open
> shared object file: No such file or directory

Did you install gtkmm3 via package or compile it yourself?  If you compiled
it yourself (and used "sudo make install" of course), sometimes libraries in
/usr/local/lib don't seem to get picked up straight away.

First of all, try running "sudo ldconfig", and then see if your app runs.

If not, it might fix itself after a little while but in the meantime you can
use "LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH path/to/your/app"

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]