ANNOUNCE: gtkmm 2.91.6



*** gtkmm 2.91:

gtkmm 2.91 (previously 2.90) wraps GTK+ 2.91. It is the gtkmm-3.0 ABI and installs in 
parallel with the gtkmm-2.4 ABI, of which gtkmm 2.20 is currently the latest stable 
version. This allows application developers to start using it when they choose to, 
without being forced, and without breaking existing installed applications.

gtkmm-3.0 will be mostly API-compatible with gtkmm-2.4, though some small 
changes will be needed in application source code.

Note that there will also be a gtkmm 2.23 (to become 2.24) version, which has small 
API additions.

gtkmm stays in-sync with GTK+ by following the official GNOME release schedule:
http://www.gnome.org/start/unstable/

Bindings for the rest of the GNOME Platform are also available, and are also 
API-stable.

http://www.gtkmm.org


*** Changes

2.91.6 (unstable):

Gtk:
* Added the StyleContext, StyleProvider, and CssProvider classes, 
  removing the Style and RC classes.
* Added Gdk::Cairo::set_source_rgba().
* Widget: Added get_style_context().
* Cellrenderer, Cellrenderertext, Cellview, Colorbutton, TextTag:
  Added RGBA versions of color properties. We expect to remove Gdk::Color 
  in future, maybe then renaming all uses of RGBA to Color.
* ColorSelection: Added get/set_current_rgba() and get/set_previous_rgba().
* ComboBoxText:
  - Renamed append_text(), prepend_text() and insert_text() to append(), 
  prepend() and insert().
  - Added extra append()/prepend()/insert() overloads that also take an id.
  - Added get/set_id_column(), get/set_active_id() and properties.
* Widget:
  - Removed the style_changed signal because it used GtkStyle, though 
  we might bring this back when the GTK+ code is completely ported to 
  GtkStyleContext.
  - Added get_path(), removing path().
  - Removed the no_expose_event signal.
* Added WidgetPath.
* Window: get_geometry(): Removed the depth parameter.

Gdk:
* Removed Drawable.
* RGBA: Rename set_rgb_p(double) to set_rgba(dobule) and rename the old 
  set_rgb(gushort) to set_rgb_u(gushort). Likewise for other methods. 
  This makes it more like GdkRGBA, which uses double instead of the gushort 
  that GdkColor used.
* Window:
  - Added set_background(RGBA) and renamed  set_background_pattern() to 
  set_background(Pattern).
	- Added set_clip_region() and get_visible_region() and create_cairo_context(),
	which were previously in the (now removed) base Drawable class.


*** Development 

There is active discussion on the mailing list: 
http://www.gtkmm.org/mailinglist.shtml
and in the #c++ channel on irc.gnome.org


-- 
Murray Cumming
murrayc murrayc com
www.murrayc.com
www.openismus.com





















[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]