ANNOUNCE: glibmm 2.16.1 released

*** glibmm 2.16.1:

glibmm is a C++ API for glib, used by gtkmm.

glibmm 2.16 wraps new API in glib 2.16, including the new gio library, 
and is API/ABI-compatibile with glibmm 2.14, 2.12, 2.10, 2.8, 2.6 and 
2.4. It is a version of the glibmm-2.4 API.

gtkmm and glibmm stay in-sync with GTK+ by following the official GNOME release schedule:

Bindings for the rest of the GNOME Platform are also available, and are also 

*** Changes:

2.16.1 (stable):

* Reference-counting bugfix in Gio::File (Murray Cumming)
* Include Gio::Error header in headers that have API that can throw this
  exception (Murray Cumming)
* Improve documentation (Murray Cumming)
* Build fixes for giomm on win32 (Jonathon Jongsma)
* fix warning with g++ 4.3 (Tim Retout)

*** Development 

There is active discussion on the mailing list:
and in the #c++ channel on

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]