Re: glibmm-2.16.4 compile error

Hash: SHA1


Damon Register schrieb:
| Andreas Haumer wrote:
|> I have about 1000 source-packages (including many c++ packages
|> like KDE), but currently only glibmm doesn't compile (after the
|> upgrade to glib-2.16.5)
| I ran into the same error I think when I built for Windows with MinGW.
| Since it was in the examples, I didn't want to waste a lot of time
| investigating so I edited the makefile to remove the examples.  Without
| the examples glibmm built fine for me.

Removing "examples" from the directory list is not enough:
the same problem occurs in the "tests" directory:

Making all in tests
make[2]: Entering directory `/work/glibmm-2.16.4/tests'
Making all in glibmm_value
make[3]: Entering directory `/work/glibmm-2.16.4/tests/glibmm_value'
g++ -DHAVE_CONFIG_H -I. -I../.. -I../../glib -I../../gio -I../../glib   -I../../glib -I../../gio        -I../../gio -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include      -g -O2 -Wall -Wno-long-long -MT main.o -MD -MP -MF .deps/main.Tpo -c -o main.o
mv -f .deps/main.Tpo .deps/main.Po
g++ -DHAVE_CONFIG_H -I. -I../.. -I../../glib -I../../gio -I../../glib   -I../../glib -I../../gio        -I../../gio -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include   -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include      -g -O2 -Wall -Wno-long-long -MT glibmm_value.o -MD -MP -MF .deps/glibmm_value.Tpo -c -o glibmm_value.o
mv -f .deps/glibmm_value.Tpo .deps/glibmm_value.Po
/bin/sh ../../libtool --tag=CXX   --mode=link g++  -g -O2 -Wall -Wno-long-long   -o test main.o glibmm_value.o  ../../glib/glibmm/ ../../gio/giomm/ -Wl,--export-dynamic -lsigc-2.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
mkdir .libs
g++ -g -O2 -Wall -Wno-long-long -o .libs/test main.o glibmm_value.o -Wl,--export-dynamic  ../../glib/glibmm/.libs/ ../../gio/giomm/.libs/ /usr/lib/ /work/glibmm-2.16.4/glib/glibmm/.libs/ /usr/lib/ /usr/lib/./ /usr/lib/ /usr/lib/ -ldl /usr/lib/  -Wl,--rpath -Wl,/usr/lib/.
../../gio/giomm/.libs/ undefined reference to `std::char_traits<unsigned char>::assign(unsigned char&, unsigned char const&)'
collect2: ld returned 1 exit status
make[3]: *** [test] Error 1
make[3]: Leaving directory `/work/glibmm-2.16.4/tests/glibmm_value'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/work/glibmm-2.16.4/tests'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/work/glibmm-2.16.4'
make: *** [all] Error 2

Removing both "examples" and "tests" directory leads to
a successful build, but leaves me a little bit nervous
about future problems I might get with glibmm...

- - andreas

- --
Andreas Haumer                     | mailto:andreas xss co at
*x Software + Systeme              |
Karmarschgasse 51/2/20             | Tel: +43-1-6060114-0
A-1100 Vienna, Austria             | Fax: +43-1-6060114-71
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]