Trying to compile gtk+ but no success cause glib

I am trying to actually compile glade3-3.4 so I need to compile loads
of other things including glib and gtk+. I have compiled and installed
glib-2.14.0 and then trying to configure gtk+.
But it says-
checking pkg-config is at least version 0.7... yes
checking for GLIB - version >= 2.13.5...
*** 'pkg-config --modversion glib-2.0' returned 2.14.0, but GLIB (2.12.11)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files
configure: error:
*** GLIB 2.13.5 or better is required. The latest version of
Then I tried to check it by hand-
[root localhost src]# FLAGS=`pkg-config glib-2.0 --cflags --libs`
[root localhost src]# echo $FLAGS
-I/gtkmm/include/glib-2.0 -I/gtkmm/lib/glib-2.0/include -L/gtkmm/lib -lglib-2.0
[root localhost src]# cc -o glib-version glib-version.c $FLAGS
[root localhost src]# ./glib-version
2 12 11
[root localhost src]# pkg-config --modversion glib-2.0
I have also downloaded glib-2.14.1 but no gain. Seems those sources
are actually 2.12.11 or my wrong! Can any one help? I am feeling
*** GLIB is always available from

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]