Gtkmm-forge digest, Vol 1 #1049 - 4 msgs



Send Gtkmm-forge mailing list submissions to
	gtkmm-forge lists sourceforge net

To subscribe or unsubscribe via the World Wide Web, visit
	https://lists.sourceforge.net/lists/listinfo/gtkmm-forge
or, via email, send a message with subject or body 'help' to
	gtkmm-forge-request lists sourceforge net

You can reach the person managing the list at
	gtkmm-forge-admin lists sourceforge net

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Gtkmm-forge digest..."


gtkmm-forge is the mailing list that receives gtkmm bug reports from bugzilla.  A daily digest is sent to gtkmm-main, to encourage people to help fixing the bugs. Do not try to unsubscribe gtkmm-forge from gtkmm-list.


Today's Topics:

   1. [Bug 328831] Dialog helper functions (gtkmm (bugzilla.gnome.org))
   2. [Bug 329333] New: A convenient wrapper of TreeView for simple ListBox'es (gtkmm (bugzilla.gnome.org))
   3. [Bug 329333] A convenient wrapper of TreeView for simple ListBox'es (gtkmm (bugzilla.gnome.org))
   4. [Bug 329333] A convenient wrapper of TreeView for simple ListBox'es (gtkmm (bugzilla.gnome.org))

--__--__--

Message: 1
To: gtkmm-forge lists sourceforge net
From: "gtkmm (bugzilla.gnome.org)" <bugzilla-daemon bugzilla gnome org>
Date: Tue, 31 Jan 2006 05:16:59 -0500 (EST)
Subject: [gtkmm bugzilla] [Bug 328831] Dialog helper functions

Do not reply to this via email (we are currently unable to handle email
responses and they get discarded).  You can add comments to this bug at
http://bugzilla.gnome.org/show_bug.cgi?id=3D328831
 gtkmm | general | Ver: 2.8.x





------- Comment #9 from baltasarq yahoo es  2006-01-31 10:16 UTC -------
(In reply to comment #8)
> I'm not convinced that any of this functionality is complicated enough =
to
> justify adding convenience functions for them within a general-purpose =
toolkit
> like gtkmm.  Within an application, I think wrappers like this are ofte=
n
> useful, but I don't really think we need to add them to gtkmm.  In any =
case, I
> think some of these things could be more cleanly implemented as special=
izations
> of the class rather than standalone wrapper functions.
>=20

Well, VCL (Borland Visual Library) has ShowMessage() and InputMessage(). =
C# in
Windows.Forms has MessageBox.Show() as an static method.

Convenience functions are there just because you want to make the life of=
 your
users [programmers] easier. Mmmm ... isn't the purpose of Gtkmm to make t=
he
life of Gtk+ users easier ?

Maybe you tought: "these are functions with two or three lines of code". =
Well
... that's true. However, creating those lines made me browse _a_lot_ of
documentation.

Whatever you like. I simply was asked to present these functions here bec=
ause
they were supposed to be of general interest. As I said in the gtkmm list=
, they
are so useful that everybody will end with their own implementation ... e=
xactly
as happened with C++ string class.


--=20
Configure bugmail: http://bugzilla.gnome.org/userprefs.cgi?tab=3Demail
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


--__--__--

Message: 2
To: gtkmm-forge lists sourceforge net
From: "gtkmm (bugzilla.gnome.org)" <bugzilla-daemon bugzilla gnome org>
Date: Tue, 31 Jan 2006 06:15:32 -0500 (EST)
Subject: [gtkmm bugzilla] [Bug 329333] New: A convenient wrapper of TreeView for simple ListBox'es

Do not reply to this via email (we are currently unable to handle email
responses and they get discarded).  You can add comments to this bug at
http://bugzilla.gnome.org/show_bug.cgi?id=3D329333
 gtkmm | TreeView | Ver: 2.8.x

           Summary: A convenient wrapper of TreeView for simple ListBox'e=
s
           Product: gtkmm
           Version: 2.8.x
          Platform: Other
        OS/Version: All
            Status: UNCONFIRMED
          Keywords: usability
          Severity: minor
          Priority: Normal
         Component: TreeView
        AssignedTo: gtkmm-forge lists sourceforge net
        ReportedBy: baltasarq yahoo es
         QAContact: gtkmm-forge lists sourceforge net
     GNOME version: 2.11/2.12
   GNOME milestone: Unspecified


User's don't have to navigate through all the TreeView's documentation to=
 just
create a simple ListBox, in which there are n rows of a simple string for=
 each
row and you can select one or more of them.

Other information:
The class lets you do common tasks directly, such as:
show()
add_row()
modify_row()
delete_row()
get_selected_rows()


--=20
Configure bugmail: http://bugzilla.gnome.org/userprefs.cgi?tab=3Demail
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


--__--__--

Message: 3
To: gtkmm-forge lists sourceforge net
From: "gtkmm (bugzilla.gnome.org)" <bugzilla-daemon bugzilla gnome org>
Date: Tue, 31 Jan 2006 06:16:59 -0500 (EST)
Subject: [gtkmm bugzilla] [Bug 329333] A convenient wrapper of TreeView for simple ListBox'es

Do not reply to this via email (we are currently unable to handle email
responses and they get discarded).  You can add comments to this bug at
http://bugzilla.gnome.org/show_bug.cgi?id=3D329333
 gtkmm | TreeView | Ver: 2.8.x





------- Comment #1 from baltasarq yahoo es  2006-01-31 11:16 UTC -------
Created an attachment (id=3D58457)
 --> (http://bugzilla.gnome.org/attachment.cgi?id=3D58457&action=3Dview)
Implementation of the ListBox wrapper for TreeView


--=20
Configure bugmail: http://bugzilla.gnome.org/userprefs.cgi?tab=3Demail
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.


--__--__--

Message: 4
To: gtkmm-forge lists sourceforge net
From: "gtkmm (bugzilla.gnome.org)" <bugzilla-daemon bugzilla gnome org>
Date: Tue, 31 Jan 2006 14:05:27 -0500 (EST)
Subject: [gtkmm bugzilla] [Bug 329333] A convenient wrapper of TreeView for simple ListBox'es

Do not reply to this via email (we are currently unable to handle email
responses and they get discarded).  You can add comments to this bug at
http://bugzilla.gnome.org/show_bug.cgi?id=3D329333
 gtkmm | TreeView | Ver: 2.8.x


jonner changed:

           What    |Removed                     |Added
-------------------------------------------------------------------------=
---
                 CC|                            |jonathon jongsma gmail c=
om




------- Comment #2 from jonner  2006-01-31 19:05 UTC -------
I actually kind of like the idea of a convenience wrapper in this case.  =
Thanks
for starting the discussion.  A couple of initial thoughts on the
implementation:

- At first glance, the name ListBox made me think that it was related to
ComboBox -- this should probably be renamed to ListView or something like=
 that
if we include it in gtkmm

- It should probably inherit from TreeView instead of creating a new clas=
s that
contains a TreeView.  That way we would retain the benefits of polymorphi=
sm.=20
As it is now, it's not a member of the Gtk::Widget heirarchy, so it could=
n't be
added directly to a container widget.  You'd have to use an ugly hack lik=
e
myContainer.add(*(myListBox.get_treeView()));

- Another impact of not using inheritance is that there's no easy way to =
access
the signals / events of the widget without calling get_treeView() and the=
n
using the TreeView interface.  I assume that even if people wanted a simp=
ler
interface for simple use-cases, they'd still need to attach to signals, s=
o
obscuring this interface doesn't seem like a good idea (yes, this is dire=
ctly
related to the previous point, but I thought I'd mention it explicitly).

- There is already a specialization like this for ComboBox called ComboBo=
xText=20
(http://www.gtkmm.org/docs/gtkmm-2.4/docs/reference/html/classGtk_1_1Comb=
oBoxText.html).
 It would be nice if the interface for this specialization could match th=
at as
closely as possible (The only real difference between them seems to be th=
at
with the ListView/ListBox you can have a multiple-selection widget wherea=
s the
ComboBox can only have single-selection).

- put_row() seems to be misnamed.  To me it looks more like it should be =
called
set_row().  Both put_row() and get_row() could be implemented with operat=
or[]()
as well.  Also note that ComboBoxText does not provide either of these
convenience functions.

- the function get_rows_number() should probably be called something like
size() instead to make it more consistent with similar existing interface=
s in
gtkmm and the standard library


--=20
Configure bugmail: http://bugzilla.gnome.org/userprefs.cgi?tab=3Demail
------- You are receiving this mail because: -------
You are the QA contact for the bug.
You are the assignee for the bug.



--__--__--

_______________________________________________
Gtkmm-forge mailing list
Gtkmm-forge lists sourceforge net
https://lists.sourceforge.net/lists/listinfo/gtkmm-forge


End of Gtkmm-forge Digest



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]