[gtkmm] A new bug???

OK, first off, I'm a gtkmm newbie.  Second, I'm not expecting any
answers.  But...

I'm trying to get up to speed with gtkmm and it's interaction under
gnome on RH8.0.  I was playing with the dnd example included in package
gtkmm-2.2.0.  I made a couple of links to the executable in the .libs
subdirectory, placing them on my desktop and had substituted a butterfly
icon on one of them (don't ask me why).  I tried drag and drop to
various opened and unopened icons/programs on the desktop just to see what would
happen.  All worked as expected, i.e. dropping on a running dnd behaved
normally, dropping on anything else not expecting that item let the
butterfly flutter back to the desktop icon.  So now I clean up, deleting
all my extra links and at least trying kill all of the active dnd

I switched back to my workspace where I'm running emacs and mozilla. 
And I'm working away and what should happen?  A butterfly comes flitting
across my screen.  It happened twice so I wasn't imagining it. No, as
far as I know there are no copies of dnd running. And no, I don't do
drugs. For the record, it followed the same path (upper left to lower
right) as seen the last time I was actually trying the app.
Finally, after 30 years of programming I've seen my first true bug!!!
Thankyou gtkmm/gnome development team, you've really made my day. And as
soon as I stop laughing I'm going to get back to work. BTW, I am
absolutely not complaining, the more I see of gtkmm and friends, the
more I like it.
Al Gelders
agelders lightspeed net
gelders fpdocs com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]