[gtkmm] Gtkmm-forge digest, Vol 1 #578 - 1 msg

Send Gtkmm-forge mailing list submissions to
	gtkmm-forge lists sourceforge net

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to
	gtkmm-forge-request lists sourceforge net

You can reach the person managing the list at
	gtkmm-forge-admin lists sourceforge net

When replying, please edit your Subject line so it is more specific
than "Re: Contents of Gtkmm-forge digest..."

gtkmm-forge is the mailing list that receives gtkmm bug reports from bugzilla.  A daily digest is sent to gtkmm-main, to encourage people to help fixing the bugs.

Today's Topics:

   1. [Bug 129396] New - libpanelappletmm-1.3.1 does not compile with older gcc (bugzilla-daemon widget gnome org)


Message: 1
From: bugzilla-daemon widget gnome org
To: gtkmm-forge lists sourceforge net, dalgoda ix netcom com
Date: Mon, 15 Dec 2003 14:36:15 -0500 (EST)
Subject: [gtkmm bugzilla] [Bug 129396] New - libpanelappletmm-1.3.1 does not compile with older gcc

Please do not reply to this email- if you want to comment on the bug, go to the
URL shown below and enter your comments there.


Changed by dalgoda ix netcom com 

--- shadow/129396	Mon Dec 15 14:36:15 2003
+++ shadow/129396.tmp.2040	Mon Dec 15 14:36:15 2003
@@ -0,0 +1,45 @@
+Bug#: 129396
+Product: gtkmm
+Version: 2.4
+OS: Linux
+OS Details: 
+Status: NEW   
+Severity: normal
+Priority: Normal
+Component: build
+AssignedTo: gtkmm-forge lists sourceforge net                            
+ReportedBy: dalgoda ix netcom com               
+TargetMilestone: ---
+Summary: libpanelappletmm-1.3.1 does not compile with older gcc
+gcc-2.95.x does not have std::locale, so we get:
+g++ -DHAVE_CONFIG_H -I. -I../../../libpanelappletmm-1.3.1/examples/simple
+-I../../libpanelapplet -I../../../libpanelappletmm-1.3.1/libpanelapplet
+-DORBIT2=1 -pthread -I/usr/include/gtkmm-2.3 -I/usr/lib/gtkmm-2.3/include
+-I/usr/include/glibmm-2.3 -I/usr/lib/glibmm-2.3/include
+-I/usr/include/gdkmm-2.3 -I/usr/lib/gdkmm-2.3/include
+-I/usr/include/pangomm-1.3 -I/usr/include/atkmm-1.3 -I/usr/include/gtk-2.0
+-I/usr/lib/sigc++-1.2/include -I/usr/include/sigc++-1.2
+-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
+-I/usr/lib/gtk-2.0/include -I/usr/include/pango-1.0 -I/usr/X11R6/include
+-I/usr/include/freetype2 -I/usr/include/atk-1.0 -I/usr/include/gconfmm-2.6
+-I/usr/lib/gconfmm-2.6/include -I/usr/include/gconf/2
+-I/usr/include/orbit-2.0 -I/usr/include/libgnomemm-2.6
+-I/usr/lib/libgnomemm-2.6/include -I/usr/include/libgnome-2.0
+-I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0
+-I/usr/lib/gnome-vfs-2.0/include -I/usr/include/bonobo-activation-2.0
+-I/usr/include/panel-2.0 -I/usr/include/libgnomeui-2.0
+-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
+-I/usr/include/libart-2.0 -I/usr/include/libxml2    -g -O2 -c
+../../../libpanelappletmm-1.3.1/examples/simple/main.cc: In function
+`static void MyApplet::size_diag(BonoboUIComponent *, void *, const gchar *)':
+../../../libpanelappletmm-1.3.1/examples/simple/main.cc:93: `::locale'
+undeclared (first use here)
+make: *** [main.o] Error 1
+Fortunately, this seems restricted to the examples directory.


Gtkmm-forge mailing list
Gtkmm-forge lists sourceforge net

End of Gtkmm-forge Digest

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]