GtkDatabox-0.9.0.0 released



Dear all,

a few minutes ago I released GtkDatabox-0.9.0.0. This release contains the long awaited reference documentation for the GtkDatabox library (volunteers for writing a tutorial are most welcome :-) ). It also contains some minor interface changes stimulated by the documentation efforts, aiming for consistency.

Please take a look at the ChangeLog:

- Added reference documentation via GtkDoc! Finally :-)
- Interface changes, inspired by the documentation:
- removed gtk_databox_redraw(). Please use gtk_widget_queue_draw()
- gtk_databox_graph_add(), gtk_databox_graph_remove(),
  gtk_databox_graph_remove_all() now return gint instead
  of gboolean or void (0 == success).
- Renamed signals (removed the "databox_" prefix and changed
  cancelled (British) to canceled (US) and harmonized:
  zoomed, selection_started, selection-changed, selection-finalized,
  selection-canceled.
- Harmonized all horizontal/vertical things to x/y:
  gtk_databox_set_hadjustment() => gtk_databox_set_adjustment_x()
  gtk_databox_set_vadjustment() => gtk_databox_set_adjustment_y()
  gtk_databox_get_hadjustment() => gtk_databox_get_adjustment_x()
  gtk_databox_get_vadjustment() => gtk_databox_get_adjustment_y()
  gtk_databox_set_hruler() => gtk_databox_set_ruler_x()
  gtk_databox_set_vruler() => gtk_databox_set_ruler_y()
  gtk_databox_get_hruler() => gtk_databox_get_ruler_x()
  gtk_databox_get_vruler() => gtk_databox_get_ruler_y()
- Harmonized property names:
  adjustment-x, adjustment-y, ruler-x, ruler-y, scale-type-x,
  scale-type-y, enable-selection, enable-zoom
- Renamed GtkDataboxMarker to GtkDataboxMarkers (plural). This is
  now consistent with GtkDataboxPoints, GtkDataboxLines and
  GtkDataboxBars. If you use GtkDataboxMarkers, you need to replace
      s/marker/markers/g
      s/Marker/Markers/g
      s/MARKER/MARKERS/g
      s/GtkDataboxText/GtkDataboxMarkersText/g
      s/GTK_DATABOX_TEXT/GTK_DATABOX_MARKERS_TEXT/g
- moved GtkDataboxGraph gc into GtkDataboxGraph priv, introduced
  gtk_databox_graph_get_gc() and gtk_databox_graph_set_gc().
- GtkDatabox inherits from GtkWidget directly instead of
  GtkDrawingArea.
- Other changes:
  - gtk_databox_auto_rescale now also works in case of data which has
    zero width and/or zero height.
- BugFixes
  - gtk_databox_graph_set_size now actually changes the line width
    (thanks to Jim George)


As you can see, a lot of details have changed. Migration should be easy, though.

Looking forward to reading your comments for the code and (of course) the documentation.

Regards,

Roland


PS: If anybody downloaded the file prior to reading this mail, please download again, I missed a few printf's during final cleanup...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]