gtkdatabox version 3.0 xs problem

Hi Muppet,
I know you are extremely busy, but your xs interface to the latest
version of gtkdatabox seems to have a small problem. I could
"experiment and guess" until I got it to run, but it may be better
if you, "with your vast knowledge and experience" looked at it.

It seems the author changed the gtkdatabox.h file from version
2.4.7 (which worked) to version 3.0 (which the xs dosn't work).

If complied against the latst version 3.0
your  Gtk2-Databox-0.001 examples will fail with:
/usr/bin/perl: relocation error: 
/usr/lib/perl5/site_perl/5.8.6/i686-linux-thread-multi/auto/Gtk2/Databox/ undefined symbol: 

It seems that the new v3 header file has 
instead of

I have tried to simply change the names to get it to run, but have
run into other problems in the examples. If I change the names
in the header file from 

It compiles, but I run into problems in the examples where you use

So I figured I would ask. :-)

I'm not really a human, but I play one on earth.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]