Re: HELP PLS: $ent->get_text and LDAP Weirdness

On Fri, 2004-09-10 at 06:12, Dirk van der Walt wrote:
I  think I'm losing it......

Here's my problem:

Upon filling in a value on an entry, the user clicks the

I go to a sub and take the value of the entry and feed it
to the Net::LDAP object, as a filter.

It hangs!

If I put a print statement in the sub, I can see the value
is correct, but it does not like coming from the entry

If I set the variable manually to the filled in value ( ie
$uname = "dvdwalt") it works 100%!

Am I missing something here?

I've tried connecting to slapd and NetWare LDAP servers,
still the same results!

Why does it not like the ?my $uname = $ent->get_text;?

the text/scalar returned from get_text will be utf8-ified and (maybe)
when you set it manually it is not. if that's the case perhaps Net::LDAP
(or the server on the other end of the line) doesn't play well with
UTF8. only a guess though.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]