Re: problems with Gtk2::ListStore

On 28 Apr 2003, Ross McFarland wrote:

On Mon, 2003-04-28 at 18:24, Chas Owens wrote:

after the following change:

    for my $dsn (@dbs) {

        for my $dsn (qw/one two three/) {

and correcting minor changes due to the fact that the second code is out
of context it works fine with for me with gtk2-perl-xs HEAD as of this

That means it has to be something weird I am doing earlier in the code.

are you using gtk-perl-xs? and if so how new? see what if anything has
changed about Gtk2::ListStore.

I was using a day or so old copy, but I updated about a hour ago and still had the problem.

i don't know what the problem could be. first thing i would try is
replacing (@dbs) with a (qw/one two three/) or something like that.

Tried it, same results.

try print Data::Dumper( $store ); and see what it says. it of course
should tell you that it's a Gtk2::ListStore.

[cowens informix2 cowens]$ perl gnome2-sql-editor
$VAR1 = bless( do{\(my $o = 142443688)}, 'Gtk2::ListStore' );
variable is not of type Gtk2::ListStore at gnome2-sql-editor line 492.

What blows my mind most about this is that $store->append returns an iterator the way it is supposed to (I 
have tried it as two lines instead of one), but set doesn't want to believe that $store is a Gtk2::ListStore.


gtk-perl-list mailing list
gtk-perl-list gnome org

I also have no problems with a simple example (the test script from my first email has no problems, so it 
must be something I am doing in the larger script, but for the life of me I can't figure out what it could be.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]