gtk-perl and perl-5.7.x

Hi there,

Build of Gtk-Perl-0.7008 seems to bomb in conjunction with
experimental perl-5.7.x versions, with the errors:

Error: 'Gtk::Gdk::Pixmap_OrNULL' not in typemap in Gtk-1.2.xs, line 173
Error: 'Gtk::Gdk::Pixmap_OrNULL' not in typemap in Gtk-1.2.xs, line 344
Error: 'Gtk::Gdk::Pixmap_OrNULL' not in typemap in Gtk-1.2.xs, line 357

This issue was discussed on this list some days ago, but without
offering any pointers on how to work around or fix it. Downgrading
to perl-5.6 is not an option for me.

Any pointers on what is wrong? Any hints on how to get it to
compile anyway? At some point in time, Gtk-Perl has to be ported
to work with perl-5.7 anyway, so..

I tried a few very obvious things like adding
Gtk::Gdk::Pixmap_OrNULL to the typemap, without avail so far, it
only made matters worse, introducing a gazillion of compilation
errors (my current knowledge about the whole XS issue, and
typemaps in particular, is very limited, chances are that I did it
the completely wrong way).

Cheers & TIA,

   Daniel Roethlisberger <daniel roe ch>
   PGP Key ID 0x8DE543ED with fingerprint
   6C10 83D7 2BB8 D908 10AE  7FA3 0779 0355 8DE5 43ED

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]