Re: [gtk-osx-users] vasnprintf() crash on macOS 10.13

Hi John,

I've just reported the issue against bison. I've tried to rebuild everything from scratch with only bison patched and it seems to be the only problem I run into with Geany - the other uses don't seem to cause problems at least for me.

Anyway, I'm afraid that at least a temporary patch will be needed in gtk-osx.


On Sat, Sep 16, 2017 at 5:34 PM, John Ralls <jralls ceridwen us> wrote:

On Sep 16, 2017, at 7:33 AM, Jiří Techet <techet gmail com> wrote:


the vasnprintf() now intentionally crashes on macOS 10.13 when the formatting string contains %n and is dynamically allocated, for more, see

This problem affects all users of gnulib's vasnprintf implementation which are at least the following (found by find . -name "vasnprintf.c" in sources which I use for compiling Geany - but there may be more):


Without any change I get the first error when compiling bison:

  CCLD     src/bison
  GEN      doc/
/bin/sh: line 1: 77605 Illegal instruction: 4  src/bison --version > doc/
make[2]: *** [doc/] Error 132
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*** Error during phase build of bison: ########## Error running make -j 9  *** [17/24]

All of the above files should probably be patched - all of them already contain a fix for the same issue under Windows which behaves the same way - I just simply tried to add a simple condition "|| defined __APPLE__" to the place where this is tested and the Windows code seems to work fine. See the above gnulib mailing list link for more info.


Thanks for reporting that. I hope that the various upstreams get their gnu lib copies updated soon. Have you checked that bugs are filed with each of the upstreams?

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]