Re: [gtk-osx-users] Support of Older OS X Versions

On Feb 23, 2016, at 11:19 PM, philip chimento gmail com wrote:

On Tue, Feb 23, 2016 at 10:40 AM John Ralls <jralls ceridwen us> wrote:
Christoph's email about pango modules and gtk-mac-bundler reminded me of another issue: GLib 2.46 includes an implementation of GNotification that uses NSNotificationCenter, available only in OS X 10.9 and later.

How important is it to everyone here that we continue to support older versions?

I'm a bit late to the thread, but I'm not immediately in favor of dropping support for <10.9. For me the answer depends on how much is the gtk-osx-build moduleset exercised on pre-10.9 machines? I contribute a lot to the modulesets, but I develop only on 10.11, and so I have no idea what my changes break on other people's setups. My feeling is that if 10.8 and lower are exercised regularly, then it's OK to continue supporting them, but if no-one has the machines or time available to do so, then it may already be broken.

On that note though, I am in favor of dropping support for 10.4 and 10.5. 10.5 is 8 and a half years old and it's been unsupported by Apple for 5 years. Not that this has anything to do with the change in GLib, but we'd be able to drop a lot of extra baggage from the jhbuildrc configuration and probably from the modulesets as well.

AFAIK every Mac built since 2010 is able to run OS X 10.11. My 2010 MBA certainly does; I bought it when the 10.7 developer preview came out so that I could test Gtk on 10.7 (darn good thing, too, there were some serious issues). Gtk has several runtime checks where we have different implementations for pre-10.7 systems. It would be a nice cleanup to get rid of them. Conversely it wouldn't be too hard to fix GLib so that the notification feature is enabled only on 10.9 and later and earlier versions just drop the notification. Making that change in git would likely get some push-back from the Gtk core group, but gtk-osx has several patches that the core group didn't like so one more is hardly a big deal.

I read the bug [1] differently, I got the impression that the change you suggest would be accepted; I think the pushback was against Ryan demanding that they drop the original patch entirely.

I'm currently releasing both GnuCash and Gramps built for 10.5 on both i386 and ppc, so the current modulesets are known to work. I haven't tried 10.4 in a long time and I rather doubt anyone else has, either. Building with the 10.5 SDK requires Xcode 3.2.9 or earlier, and that doesn't work on 10.11, so I have to use a 10.10 VM. On Gramps I've had to hold back Gtk+ to 3.14; 3.16 has serious stability issues which I suspect are also due to the obsolete compiler.

But Gramps does annual "major" releases and I'm going to stop doing the PPC build and do 10.9 or later for i386 beginning with that release, and will probably do the same for GnuCash at its next major release at the end of next year.

The only Gtk core member who commented on that bug was Emmanuele, and he was pretty clear that he doesn't think it's GLib's business to support the "retro computing scene". The discussion on gtk-devel didn't happen, but perhaps I should raise it there. Ryan Schmidt didn't demand that the whole patch be removed, only that it be redone so that it doesn't require 10.9 or newer.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]