[gtk-osx-users] [Gtk-osx-users] jhbuild issues

I am trying to rebuild latest stable version of GTK2.x, my setup is:
          -   OSX version 10.7.5
          -   XCode 4.2 (gcc 4.2.1)
          -   using modulesets-stable
          -   Relevant parts of .jhbuildrc-custom file:
                  setup_sdk(target="10.6", sdk_version="10.6", architectures=["i386"])
                  os.environ["ARCHFLAGS"] = "-arch x86_64 -arch i386"
           -  Relevant parts of my build procedure:
                  jhbuild bootstrap --skip=libiconv
                  jhbuild build python
                  alias jhbuild="PATH=gtk-prefix/bin:$PATH jhbuild"
                  jhbuild build meta-gtk-osx-bootstrap
                  jhbuild build meta-gtk-osx-core
                  jhbuild build meta-gtk-osx-themes
                  jhbuild build gtk-mac-integration
                  jhbuild build gtksourceview

I am having 3 issues right now:

1.) Latest libffi won't build. This appears the known issue related to the old compile tool versions, see here:

I've solved the issue by downloading older version (libffi-3.0.9.tar.gz) from ftp://sourceware.org/pub/libffi/
and using that one.

2.) Glib compilation fails, this also seems to be related to old compile tools versions on my platform.
Errors are following:
          ../../gio/glistmodel.h:36: error: redefinition of typedef 'GListModel'
          ../../gio/giotypes.h:64: error: previous declaration of 'GListModel' was here

This also seems to be known issue, see discussion here:

I've solved the issue by applying this patch (i.e. deleting two lines from giotypes.h):

3. ) gtksourceview configuration fails with the following error:

checking for GTK_MAC... no
configure: error: Package requirements (gtk-mac-integration) were not met:

No package 'gtk-mac-integration' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GTK_MAC_CFLAGS
and GTK_MAC_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Note that gtk-mac-integration was correctly build and installed in previous step:

*** Installing gtk-mac-integration *** [29/37]
I: Install complete: 38 files copied

Any idea on how to resolve the issue with gtksourceview?


PS. BTW GTK in the stable moduleset is stuck at v2.24.21 dating back to year 2013.
It would be nice to see that updated to latest v2.24.28.
One dashboard for servers and applications across Physical-Virtual-Cloud 
Widest out-of-the-box monitoring support with 50+ applications
Performance metrics, stats and reports that give you Actionable Insights
Deep dive visibility with transaction tracing using APM Insight.
Gtk-osx-users mailing list
Gtk-osx-users lists sourceforge net

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]