[gtk-osx-users] Building on PPC fails - what is the current status?

Dear all,

I have also tried to get a running GTK2 on a PowerPC Mac mini
with Tiger OSX (as Steffen Gutmann did in January).

My first attempts using Macports failed; I have applied
several proposed patches from the thread between Steffen and
John (like for gdkimage-quartz.c and gtkquartz.h). At least
I succeeded in building gtk2, but gtk-demo also had the fonts
missing (as in Steffen's build)

First I tried to build universal, but now I am limiting myself
to a plain PPC build to minimize complexity.

As Macports did not work out, I wiped it off completely and
tried jhbuild.

This also has not been successful.

Starting gtk-demo with the build user brings up
  kCGErrorRangeCheck : Window Server communications from outside of
  session allowed for root and console user only
  INIT_Processeses(), could not establish the default connection
  to the WindowServer.Abort trap

Starting gtk-demo as root brings up
  code should not be reached

I have also built the meta-gtk-osx-freetype module after fixing
the known quirks (like the references to OSAtomicCompareAndSwapPtrBarrier) and rebuilt pango.

So you might understand why I am a bit frustrated, because I only
want to port a GTK2 program from Windows to Mac and unfortunately
Tiger is a requirement here.  But I am trying to fix things for
several weeks to get up GTK2 and the missing fonts problem is the
only remaining obstacle.

Steffen, did you succeed in getting GTK2 to work on 10.4 or did
you finally switch to Leopard?

             Best regards,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]