[gtk-osx-users] Error: jhbuild build fails to parse gtk-osx.modules


When I run

$ jhbuild build meta-gtk-osk-bootstrap

I get the following error:

jhbuild build: failed to parse http://git.gnome.org/browse/gtk-osx/plain/modulesets-stable/gtk-osx.modules: not well-formed (invalid token): line 57, column 6

I am running OSX 10.6.8.

I have tried some sleuthing on my own but as far as I can tell the gtk-osx.modules document is well-formed. I am not very familiar with how jhbuild or GTK work (I am just trying to follow these instructions, as a means to an end).

For a bit of background, incase it is relevant, I am trying to get a simulator program for my robotics course to run on my Mac. It uses this Python module, which requires GTK Python libraries. I have libraries installed already but when I run the module's test script I get errors that look like this:
... __NSAutoreleaseNoPool(): Object 0x1026669e0 of class NSCalibratedWhiteColor autoreleased with no pool in place - just leaking
... attempt to pop an unknown autorelease pool (0x100a07a00)
and the program stops responding (with a blank window open). These are apparently Cocoa errors to do with threading but I have yet to find out much more than that. My assumption has been that my GTK libraries were bad. But I have never worked with GTK, Cocoa, or even Python before yesterday so I am not sure if I am on the right track.

Any help to get me moving again would be greatly appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]