[gtk-osx-users] gtk-osx jhbuild and XCode 4.4.1 on Lion


I have already built gtk applications with gtk-osx just fine in the past
(Snow Leopard and Xcode 3 and 4).

However I can not even get meta-gtk-osx-core on the default moduleset to
build with the newest Xcode 4.4.1 on Mac OS 10.7 (Lion).

So build environment :
* Mac OS 10.7.4 (64-bit)
* Xcode 4.4.1 (4F1003)
* Xcode 4.4 Command line tools for Lion (Aug 2012)
  including Apple/clang 421.0.60

Originally I tried building :
target="10.4", sdk_version="10.6", architectures=["i386"]
(using an old 10.6 SDK in /Developer)

which leads to the following error :
*** Installing freetype *** [4/14]
make install
make: *** No rule to make target `install'.  Stop.
*** Error during phase install of freetype: ########## Error running
make install *** [4/14]

a further looks gives :
bash-3.2$ make
cc  -I/Users/gtkdev2/gtk/inst/include
-I/Developer/SDKs/MacOSX10.6.sdk/usr/include -I./objs -I./builds/ansi
-I./include -arch i386 -I/Developer/SDKs/MacOSX10.6.sdk/usr/include
-isysroot /Developer/SDKs/MacOSX10.6.sdk -mmacosx-version-min=10.4
objs/ftsystem.o src/base/ftsystem.c
Undefined symbols for architecture i386:
  "_main", referenced from:
      __start in crt1.o
ld: symbol(s) not found for architecture i386
collect2: ld returned 1 exit status
make: *** [objs/ftsystem.o] Error 1

I can circumvent this error by commenting out the
then do another configure and recompile
which was suggested in a list post on the gtk-list here :

then it builds and installs just fine (of course without the

but then jhbuild halts at gtk+ :
libtool: install: /Users/gtkdev2/.local/bin/install-check
make  install-data-hook
/bin/sh /Users/gtkdev2/gtk/source/gtk+-2.24.9/install-sh -d
../../gtk/gtk-query-immodules-2.0 >
dyld: lazy symbol binding failed: Symbol not found: _objc_msgSend
  Referenced from:
  Expected in:

dyld: Symbol not found: _objc_msgSend
  Referenced from:
  Expected in:

/bin/sh: line 1: 62251 Trace/BPT trap: 5
../../gtk/gtk-query-immodules-2.0 >
make[4]: *** [install-data-hook] Error 133
make[3]: *** [install-data-am] Error 2
make[2]: *** [install-am] Error 2
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1
*** Error during phase install of gtk+: ########## Error running make
install *** [12/14]

I also tried building
target="10.4", sdk_version="10.7", architectures=["i386"]
target="10.4", sdk_version="10.7", architectures=["x86_64"]
which didn't improve anything - it still doesn't build.

Then I tried it in a clean Lion VM just with XCode 4.4.1 and the Dev
Tools to rule out any environmental issues on my system. This didn't
help either.

The I tried out Xcode 4.1 which uses old apple gcc instead of llvm on
10.7.4 in a clean vm and it gave the same errors.

Should this work ?
Or did I just do some stupid mistake I don't see ?

Any help would be appreciated.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]