Re: [gtk-osx-users] PyGTK 2.24.0 not working on Snow Leopard

On Oct 25, 2011, at 11:42 PM, Dwayne Bailey wrote:


I've been building PyGTK against Snow Leopard and I also got the error mention in the thread 'PyGTK on Lion'.

Traceback (most recent call last):
  File "", line 12, in <module>
    import gtk
  File "/Users/gtk-osx/gtk/inst/lib/python2.7/site-packages/gtk-2.0/gtk/", line 40, in <module>
    from gtk import _gtk
ImportError: dynamic module does not define init function (init_gtk)

So I'm afraid this seems to be a problem that impact 10.6 also

I tried the changes mentioned in
those didn't help.  I can't recall the error, I can replicate it if that helps.

I then tried compiling PyGTK 2.24 with the autogen used for 2.22 hoping that the fixes in the moduleset's autogen for PyGTK might only be needed for 10.7.  That didn't work.

In the end I've reverted to PyGTK 2.22 which compiled smoothly.  My app is running well now.

Yes, the screwed-up libtool in PyGtk 2.24 affects all SDKs. I've got a patch worked up to work around it which I expect to push tomorrow.

John Ralls

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]