Re: [Gtk-osx-users] unable to build on 10.6.6

On Mon, 07 Feb 2011 16:34:12 -0500, John Ralls <jralls ceridwen us> wrote:

On Feb 7, 2011, at 11:55 AM, Anthony Dardis wrote:

Dear GTK+-2 OSX Users,

On a MacBook Pro, Intel Core 2, OS X 10.6.6,

jhbuild bootstrap

fails; the last few lines of the output are

/usr/bin/gcc-4.0 -std=gnu99 -I. -I/Users/prog/gtk/inst/include -I/Developer/\ SDKs/MacOSX10.6.sdk/usr/include -I/Developer/SDKs/MacOSX10.4.sdk/usr/include -\ arch i386 -I/Developer/SDKs/MacOSX10.6.sdk/usr/include -arch i386 -I/Developer/\ SDKs/MacOSX10.4.sdk/usr/include -arch x86_64 -mmacosx-version-min=10.6 -isysroo\ t /Developer/SDKs/MacOSX10.4.sdk -mmacosx-version-min=10.4 -isysroot /Developer\ /SDKs/MacOSX10.6.sdk -mmacosx-version-min=10.6 -MT gl_avltree_oset.o -MD -MP -M\ F .deps/gl_avltree_oset.Tpo -c -o gl_avltree_oset.o gl_avltree_oset.c gcc-4.0: -E, -S, -save-temps and -M options are not allowed with multiple -arch\ flags
make[3]: *** [gl_avltree_oset.o] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2 *** Error during phase build of m4: ########## Error running make *** [2/10]

I started out by clearing everything out of the account; then


then edited .jhbuildrc-custom and put the following 3 lines at the end:

moduleset = "";
setup_sdk(target="10.4", sdk_version="10.4", architectures=["i386"])
setup_sdk("10.6", "10.6", ["i386"])

(following the two sets of instructions for building on Snow Leopard), then did

jhbuild boostrap

I tried the same process but without the line

setup_sdk(target="10.4", sdk_version="10.4", architectures=["i386"])

(guessing here about "multiple -arch flags") but got the same result.

I have Python 2.6.1, svn 1.6.5, and git installed, and the developer tools from Xcode from the install DVD (for example, i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5646)

Do it again, making sure that you call setup_sdk() exactly once in your jhbuildrc-custom, and post the actual output from that run. If there are two sets of CFLAGS, especially if they have different SDKs, then you've either got two calls to setup_sdk() or you're trying to build from inside a jhbuild shell.

Thanks, John, that did it: I commented out the setup_sdk() call that .jhbuildrc-custom initially supplies, put in this one:

setup_sdk("10.6", "10.6", ["i386"])

along with the 'moduleset =', etc., to get the stable modulesets, and the whole build succeeded (that is, the three steps

jhbuild bootstrap
jhbuild build meta-gtk-osx-bootstrap
jhbuild build meta-gtk-osx-core

all succeeded).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]