Re: Having trouble with cursors

On 7/19/17, Stu Whitman <swhitman groupw com> wrote:

I use gtk3 on CentOS 6 by building it and all of the dependencies myself. I
recently updated to version gtk+-3.22 from gtk+-3.8. When I run the
gtk3-widget-factory program the cursor image does not switch to the
col-resize cursor when over the GtkPaned widget handle. The cursor changes
from an arrow with a border to a simpler arrow with no border. It also does
not switch to the hand pointer when over the Wikipedia link. Any idea how to
fix this?

----- On Jul 20, 2017, at 11:51 AM, Carsten Mattner carstenmattner gmail com wrote:

Are you possibly using a theme made for 3.8?

I always start fresh, installing into an empty prefix folder. For 3.8 I built gnome-themes-standard-3.8.4. I 
tried to update this package, but the README said that the Adwaita theme is included in GTK3, so I did not 
include gnome-themes-standard in the 3.22 build. My first attempts at using 3.22 did not have all of the 
icons needed. I then found the adwaita-icon-theme and hicolor-icon-theme packages. Once I built these, my 
icon issues went away, but it did not fix the cursor issue.

I have some more information from doing an strace. The $prefix/share/icons/Adwaita/index.theme file is found 
(eventually) and read. I can see the icon files being accessed under the $prefix/share/icons/Adwaita folder. 
I then searched for col-resize. This file is never found. These folders are searched:

The file is in the folder $prefix/share/icons/Adwaita/cursors, placed there by the adwaita-icon-theme 
package. Why does it not attempt to search for cursors under Adwaita when it knows to search for icons there? 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]