Re: GLib Installation Issues

On Tue, Jan 17, 2012 at 11:36:14PM +0000, Jon Pisani wrote:
> I am trying to install Ettercap 0.7.4 on my Backtrack 5 R1 box. One of the dependencies is glib 2.0.0 or greater. I successfully installed it with no errors, but when I go to install other dependencies that require glib, I get the following error.
> checking for GLIB - version >= 2.0.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.30.2, but GLIB (2.24.1)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> configure: error:
> *** GLIB 2.0.0 or better is required. The latest version of
> *** GLIB is always available from If GLIB is installed
> *** but not in the same location as pkg-config add the location of the file
> *** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.
> I don't know how to properly uninstall the previous version. Can you please advise?

Do the opposite of what you did to install it? (Did you install the old
version from source, or use some sort of packaging framework which comes
with your OS? eg instead of aptitude install, try aptitude remove|purge?)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]