Re: Having problems installing ATK, getting configure error regarding glib

i had previously installed 2.32.0 then uninstalled and deleted it.and i had posted the error log from previous installation.
but after installing 2.32.4 ,i checked it again,it was giving the same error.
but now i decided to post the fresh error for 2.32.4,and i cant believe my eyes.i am checking again and again whether its atk that just got compiled.the thing which was not compiling for last 1 day with all efforts suddenly is getting i did 'make' .it is a success.then i did 'make install'. that too performed successfully.there can be only one reason for it getting compiled this time.last time i was messing with library paths and pkg config paths and i never closed terminal after downloading 2.32.4.and there was obviously problem in 2.32.0 because it was somehow clashing with system glib.
Thanks to you would never have been possible without a discussion.

On Fri, Aug 24, 2012 at 11:47 PM, ajinkya jayawant <ajinkyajayawant gmail com> wrote:

i am trying to install gtk+ on Ubuntu 11.04.i have followed instructions from "".i have installed packages glib (2.32.4),pango(1.30.1), cairo(libcairo2-dev).

i have done








I am now tring to install atk

But when i do ./configure --prefix=/home/jink/gtkin in terminal after doing cd to proper folder i get the following error.

checking for GLIB - version >= 2.31.2...

*** 'pkg-config --modversion glib-2.0' returned 2.32.0, but GLIB (2.32.4)

*** was found! If pkg-config was correct, then it is best

*** to remove the old version of GLib. You may also be able to fix the error

*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing

*** /etc/ Make sure you have run ldconfig if that is

*** required on your system.

*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH

*** to point to the correct configuration files


configure: error:

*** GLIB 2.31.2 or better is required. The latest version of

*** GLIB is always available from If GLIB is installed

*** but not in the same location as pkg-config add the location of the file

*** glib-2.0.pc to the environment variable PKG_CONFIG_PATH.

i have tried doing



./configure --prefix=/home/jink/gtkin PKG_CONFIG_PATH="/home/jink/gtkin"

./configure --prefix=/home/jink/gtkin PKG_CONFIG_PATH=/usr/lib

i have tried installling and uninstalling glib twice or thrice and installing another version.but i am getting the same error.i am not able to understand what to do now,please help.

i dont know whether attachments get sent in this mailing list or not so i am sending config.log file as another mail.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]