glib osx: 'error: only weak aliases are supported'

Hey all-

I had successfully built glib-2.24.0 on OSX previously, but I recently tried to recompile it, and got a bunch of "error: only weak aliases are supported in this configuration" errors. I saw that 2.24.1 had been released, so I tried this version, and got the same error.

I am 95% sure that I had built it on 10.6.3, so this may be related to something in 10.6.4. Note that I'm also building it with a prefix, and so I'm also compiling dependancies by hand. Here's the script I made to do the building:

Note that while this script doesn't actually detect errors, I noticed that there were some, and so re-ran each line by hand. Everything works great up until the glib make && make install, and this script worked great in its entirety earlier.

Here's the exact error output:

Does anyone have any ideas? I did some googling, but didn't find anything. Thanks in advance.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]