Re: GTK+ 2.21.6

On Wed, Aug 18, 2010 at 12:21 PM, Bastien Nocera <hadess hadess net> wrote:

> New functionality is available in both when it makes sense to do so, and
> deprecated functionality is marked as much.
> You shouldn't see any difference in usage if you don't use the new
> functionality.

We distribute a version of GTK as part of our product for OS X. We had
selected 2.22 as the branch to follow for this, on an apparently
faulty understanding that 2.22 was a relatively stable branch at this
point. Replacing every gdk_draw_* method doesn't qualify for
"relatively stable" in my opinion. We now have to drop our tracking of
2.22 entirely and simply sit at the current (arbitrary) revision that
we currently use for the build. Frustrating. We went through this
earlier (at about 2.14), when we had to stop tracking releases because
of the breakage being caused to non-X11 backends by changes to various
parts fo the system. I guess we just do the same again. It only
affects a handful of developers but it also pretty much blocks anyone
from ever being able to "easily" build our GPL'ed app on OS X for
themselves because there will never be a release version of GTK that
corresponds to what is required.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]