Re: The naming of GTK+ signals

On Sun, Nov 22, 2009 at 11:59:01AM -0500, Guofu Chen wrote:
> The naming of signals are of 2 versions so far that I can see:
> gtk_drag_get_data ()
> gtk-drag-get-data ()
> and I get very confused for that.
> Can somebody explain that please?

gtk_drag_get_data() is the name of a *function*.  Unless you use bindings
for some exotic language (apologies to LISPers) gtk-drag-get-data is not
a vaild name, function names can only contain underscores.  So I'm not
sure what you mean.

Anyway, for *signal* names both forms are recognized and equivalent,
"drag-data-get" or "drag_data_get".

The canonical form is with dashes, e.g. "drag-data-get".  The API
documentation should always display signal names in this form.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]