glib-2.12.12 build problem - gparamspecs.c

I’m trying to build a version of glib and gtk to match a gtkmm version on a different system.  The target system is using the Mips-pro version 7.4.4m. When I run ./configure on glib-2.12.12 and or glib-2.12.13 I get the following error when it tries to build gparamspecs.c:


make[3]: Entering directory `/vobs/local/src/irix_build/glib-2.12.12/gobject'

source='gparamspecs.c' object='gparamspecs.lo' libtool=yes \

depfile='.deps/gparamspecs.Plo' tmpdepfile='.deps/gparamspecs.TPlo' \

depmode=sgi /bin/sh ../depcomp \

/bin/sh ../libtool --mode=compile cc -DHAVE_CONFIG_H -I. -I. -I.. -DG_LOG_DOMAIN=\"GLib-GObject\" -I.. -I../glib -I.. -DG_DISABLE_CAST_CHECKS -DG_DISABLE_DEPRECATED -DGOBJECT_COMPILATION -DG_DISABLE_CONST_RETURNS  -I/vobs/local/irix/include -I/usr/local/include -D_REENTRANT  -I/usr/local/include -c -o gparamspecs.lo `test -f 'gparamspecs.c' || echo './'`gparamspecs.c

 cc -DHAVE_CONFIG_H -I. -I. -I.. "-DG_LOG_DOMAIN=\"GLib-GObject\"" -I.. -I../glib -I.. -DG_DISABLE_CAST_CHECKS -DG_DISABLE_DEPRECATED -DGOBJECT_COMPILATION -DG_DISABLE_CONST_RETURNS -I/vobs/local/irix/include -I/usr/local/include -D_REENTRANT -I/usr/local/include -c gparamspecs.c -Wp,-MDupdate,.deps/gparamspecs.TPlo  -DPIC -o .libs/gparamspecs.o

cc-1028 cc: ERROR File = gparamspecs.c, Line = 1478

  The _expression_ used must have a constant value.


        value_type,             /* value_type */



1 error detected in the compilation of "gparamspecs.c".


I also tried to compile glib-2.12.0 and got a bunch of errors in different files.


Any suggestions?




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]