Re: Regarding GLIB 2.4.0

On Mon, May 28, 2007 at 01:00:40PM +0530, Sashi Kiran Akella wrote:
>          When I'm installing gtk+-2.4.0, I'm getting the following error:
> checking for GLIB - version >= 2.4.0...
> *** 'pkg-config --modversion glib-2.0' returned 2.4.0, but GLIB (2.6.0)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GLib. You may also be able to fix the error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files
> no
> configure: error:
> *** GLIB 2.4.0 or better is required. The latest version of
> *** GLIB is always available from
>  Please help me come out of this problem.

- actually read the configure error message, it explains what
  went wrong and what you should do
- remove anything you installed to system directories from
  sources and/or restore it from the distro packages and
  generally get your system to the orignal sane state
- follow



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]