Re: Regarding rpm installation of gtk

On Mon, Jun 04, 2007 at 09:46:35AM +0530, Sashi Kiran Akella wrote:
>        I've installed a RPM related to gtk which is 2.6.1-2. After if I 
> query as rpm -q gtk+- it is giving the installed rpm as gtk+-2.6.1-2, 
> but again error is coming when I'm trying to install one application 
> like this :
> checking for PACKAGE... Requested 'gtk+-2.0 >= 2.4.0' but version of 
> GTK+ is 2.3.5
> configure: error: Package requirements (gtk+-2.0 >= 2.4.0 libglade-2.0 
> glib-2.0 gthread-2.0) were not met:
> ...
> Please anyone help me come out of this problem.

So, pkg-config found Gtk+ 2.3.5.
What could be possibly the reason why it found Gtk+ 2.3.5?
Well, it found Gtk+ 2.3.5 because you have Gtk+ 2.3.5
installed somewhere.

Now, if you know you have a Gtk+ 2.3.5 installation (or
remains of it) somewhere, you should be able to find it
using locate or other standard means.  However, as you know
pkg-config found it, you can ask pkg-config:

  pkg-config --variable=prefix gtk+-2.0
  pkg-config --debug gtk+-2.0 2>&1 | grep 'gtk+-2.0.*file'

The first command prints where the Gtk+ installation thinks
to be located (more precisely the prefix), the second
command prints where the .pc file actually is (normally
these locations are consistent).

What remains: to remove the offending installation of Gtk+



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]