Re: Problem when running "./configure" - gtk+-2.10.9


Here is the error message from the config.log file:

configure:33958: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see


David Nečas (Yeti) <yeti physics muni cz>

02/19/2007 02:37 PM
Please respond to
gtk-list gnome org

gtk-list gnome org, avassilicos uss com
Re: Problem when running "./configure" - gtk+-2.10.9

On Mon, Feb 19, 2007 at 12:08:35PM -0500, Achilles Vassilicos wrote:
> I have encountered the following problem when I run:
> "./configure --prefix=/usr --sysconfdir=/etc --libdir=/usr/lib"

So you are subverting the packaging system, overwritting
system libs and have probably already done this for more
than couple of them?  Uh, oh.

> ...checking Pango flags...
> Configure error:
> *** can't find Pango

Is the exact error message?  Gtk+'s configure does not seem
to be able of printing this.

> No other error messages during configure.

Please include the exact error message.  Include also the
relevant parts of config.log (while looking for the relevant
parts are you can also find out what the problem is, but
include all of it in the worst case).

> I am running Redhat W4/UPD4 on an intel-64 box.

But first of all restore the system to a sane state.  Restore
the overwritten files from rpm (--replacepkgs --replacefiles)
and then remove the bits that were not replaced by anything
from rpm (removing libs can render your system unusable
therefore the reverse order is likely to cause troubles).

Then choose a non-system prefix and install everything there,
see for example

> I have installed Pango successfully.  I tried several versions of Pango,
> from the latest 1.15.6 to earlier versions of 1.14.10 with the same
> problem.  Pango is installed with --prefix=/usr.  Latest version of Cairo
> is installed as well as the latest versions of [pkgconfig] and [glib-2.0].
> The directory /usr/lib/pkgconfig contains all the .pc files for Pango.
> Any suggestions?

Don't do that.

But if you insist, look up the error in the configure script
and either insert some debugging messages or try to manually
reproduce what it does to see why it does not like what it

> Please reply to me directly at <avassilicos uss com> because my company's
> firewall does not allow to go to the list web page to view replies.

Citing the e-mail header:

List-Subscribe: <>,
<mailto:gtk-list-request gnome org?subject=subscribe>




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]