GTK+ 2.8.4 gtk-demo seg faults immediately on Solaris 9

Has anyone been able to run gtk-demo on a SPARC Solaris 9 host?
I compiled it successfully from source code (using gcc 3.3.2)
with dependencies shown by the following shell variables from
my build script:

set atk_version        = "1.10.1"
set autoconf_version   = "2.59"
set automake_version   = "1.9.6"
set cairo_version      = "1.0.0"
set expat_version      = "1.95.8"
set fontconfig_version = "2.3.2"
set freetype_version   = "2.1.10"
set glib_version       = "2.8.2"
set glitz_version      = "0.4.4"
set gtk_version        = "2.8.4"
set libpixman_version  = "0.1.6"
set libpng_version     = "1.2.8"
set libtool_version    = "1.5.20"
set pango_version      = "1.10.0"
set pkgconfig_version  = "0.19"
set render_version     = "0.9"
set xft_version        = "2.1.7"
set xrender_version    = "0.9.0"

These are the latest versions I could find.  The Solaris 9 host has
been recently patched with a Sun jumbo patch.

When I run gtk-demo, it seg faults right after displaying the main
window.  When I run gtk-demo via gdb to get a stack trace, it doesn't
crash and mostly works (there are a few problems, but most things in
the demo work).  

Running ldd to see which shared libraries are being used gives
the expected results.

Any ideas about how to investigate this further?  Has anyone been
able to successfully run GTK+ 2.8.4 on a SPARC Solaris 9 host?

David Hollenberg

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]