Request for help again....

Please help me with this... I am trying to cross compile GTK+ to ARM

I have successfully cross-compiled X, gcc, zlib, libjpeg, libpng,
pkg-config, glibc 2.6.4, atk 1.9.0, pango 1.8.1 and and subsequently
trying to cross compile GTK+ 2.6.6 on Fedora Core 3 system.

checking XCURSOR_CFLAGS... -I/opt/q+esto/cdt/arm-linux/usr/X11R6/include
checking XCURSOR_LIBS... -L/opt/q+esto/cdt/arm-linux/usr/X11R6/lib -lXcursor
checking for XSyncQueryExtension in -lXext... yes
checking for X11/extensions/sync.h... no
checking for xfixes... Package xfixes was not found in the pkg-config
search path.
Perhaps you should add the directory containing `xfixes.pc'
to the PKG_CONFIG_PATH environment variable
No package 'xfixes' found
checking sys/ipc.h usability... yes
checking sys/ipc.h presence... yes
checking for sys/ipc.h... yes
checking sys/shm.h usability... yes
checking sys/shm.h presence... yes
checking for sys/shm.h... yes
checking X11/extensions/XShm.h... yes
checking Pango flags... -I/opt/q+esto/cdt/arm-linux/include/pango-1.0
-L/opt/q+esto/cdt/arm-linux/lib -lpangoxft-1.0 -lpangox-1.0
-lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
configure: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see
[root joe-linux gtk+-2.6.6]#

I have the Pango libraries libpango, libpangox, libpangoft2 and
libpangoxft and they r in the correct path...

I could previously solve this error for another toolchain by patching
the pangoxft.pc to include pangoft2 and xft and rebuilding
for the current toolchain...this dosent work either...

Please help...

Please guide me what could be the possible error...

Thank you

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]