installing glib and gtk - new versions

I'm trying to install new versions of Glib and GTK over old on RH Enterprise Linux AS, but receive the following errors when I try ./configure GTK-2.6.2

checking for glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0... Requested 'glib-2.0 >= 2.6.0' but version of GLib is 2.2.3
configure: error: Library requirements (glib-2.0 >= 2.6.0    atk >= 1.0.1    pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.

I removed the previous version with RPM -e, but maybe not everything was removed.  I'm not sure if tar is putting everything in the right places either.  How can I make these things certain?  Are there other reasons I'm getting these errors?  Why does Redhat not use these versions?

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]