problem building gtk2.4.1


Like another writer, I am trying to build gimp2.0 (in my case under red
hat 9). As I understand the dependencies, gimp requires gtk+-2.4.1,
pango-1.4, and others. These require glib-2.4 or better.

Going to the lowest level, I downloaded glib-2.4.1 source.
I built using ./configure, make, and make install.
The only files I see generated are,
and pango-1.4 configure fails, saying I need version >= 2.4
Can anyone clarify what's going on?


ps. As a final note, I hope I get some useful information rather than
flames. I am a sophisticated programmer, but that is no guarantee of
being able to unravel someone else's (undocumented) dependency problems.
Compare the situation to other peoples' packages: If I build gcc on a
normal platform, it simply builds. If I am building a cross-compiler for
some arcane little processor, then I might expect trouble. There is no
intrinsic reason why this install has to be so much more difficult than
any other. I would dearly love to just install binary rpms if only they
were available for my platform. 

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]