Re: gtk 2.4 compilation wants pango 1.2?


Dave Reed <dreed capital edu> writes:

> On a Solaris 9 system, I installed:
> glib-2.4.0
> pango-1.4.0
> atk-1.6.0
> but when configuring gtk+-2.4.0 I get:
> -----------------------------------------------------------------
> checking for freetype-config... /usr/local/bin/freetype-config
> checking For sufficiently new FreeType (at least 2.0.1)... yes
> sh: gnome-config: not found
> configure: error: Pango 1.2.0 and Xft backend is required for x11 target
> -----------------------------------------------------------------
> I had previously installed gtk+-2.2.2 and it's corresponding glib,
> pango, and atk. What do I need to do to get gtk 2.4 to install?

You need pango >= 1.2.0 (so 1.4.0 is OK) _with_ the Xft backend. Use
'pkg-config --modversion pangoxft' to find out what version is
installed (or rather what version is in your PKG_CONFIG_PATH).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]