Re: GTK & Gimp confusion


Brad Kligerman <bkliger club-internet fr> writes:

> I've already followed the errors msgs recommendations, but still get
> the same result.
> When I do>>>>>>> $ rpm -qa | grep gtk+
> I get>>>>>>>
> gtk+-devel-1.2.10-25
> gtk+-1.2.10-25
> And for >>>>>> $ rpm -qa | grep gtk2
> I get >>>>>>>>>>>
> pygtk2-devel-1.99.14-4
> pygtk2-1.99.14-4
> gtk2-2.2.1-4
> gtk2-devel-2.2.1-4
> pygtk2-libglade-1.99.14-4
> gtk2-engines-2.2.0-2
> I thought that I was installing GTK+ 2.2.4 and I get
> _gtk2-2.2.1-4_. Is this normal?? GIMP is finding GTK+ (2.2.1).
> Can anyone help me figure this out? Thanks.

Your distribution has installed gtk+-2.2.1 build 4. This is labelled
as gtk2-2.2.1-4. Now if you install gtk+-2.2.4 from source, you have
two versions of GTK+ installed and your distributions' package manager
will still report gtk2-2.2.1-4.

> checking for pkg-config... (cached) /usr/bin/pkg-config
> checking for GTK+ - version >= 2.2.2...
> *** 'pkg-config --modversion gtk+-2.0' returned 2.2.4, but GTK+ (2.2.1)
> *** was found! If pkg-config was correct, then it is best
> *** to remove the old version of GTK+. You may also be able to fix the
> error
> *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
> *** /etc/ Make sure you have run ldconfig if that is
> *** required on your system.
> *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
> *** to point to the correct configuration files no

So pkg-config happily finds the newer version of GTK+ but the linker
still prefers the old version installed by your distribution. So you
either need to uninstall 2.2.1 or persuade the linker to prefer the
version you installed. You can do the latter by modifying the linker
search path. The error message above explains how to do this.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]