GTK & Gimp confusion

Hi all/

I'm an end user simply trying to upgrade GIMP from the version that was loaded w/ RH9, BUT my question concerns GTK. GIMP's configure script returns an error every time with the following message>>>>

[root localhost gimp-1.3.23]# ./configure
checking for pkg-config... (cached) /usr/bin/pkg-config
checking for GTK+ - version >= 2.2.2...
*** 'pkg-config --modversion gtk+-2.0' returned 2.2.4, but GTK+ (2.2.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GTK+. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files no
configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

I've already followed the errors msgs recommendations, but still get the same result.
When I do>>>>>>> $ rpm -qa | grep gtk+
I get>>>>>>>
And for >>>>>> $ rpm -qa | grep gtk2
I get >>>>>>>>>>>

I thought that I was installing GTK+ 2.2.4 and I get _gtk2-2.2.1-4_. Is this normal?? GIMP is finding GTK+ (2.2.1).
Can anyone help me figure this out? Thanks.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]