New File chooser widget

I've just modified one of my programs to use the new gtk2.4 file chooser
widget. I've used a file chooser dialog which is coded almost
exactly as the manual example. Everything works fine except that when I
run the program in a terminal window I get the following warning
message: Glib-Gobject-WARNING **: cannot register existing type
`GnomeIconTheme`. The first time the dialog is opened this does'nt occur
but it does on all subsequent openings. The warning repeats for all
entries in the active directory and whenever the mouse pointer passes
through them. I'm running under FC2T2 using the gnome desktop and
BlueCurve theme. All the icons in the filechooser look ok. I also get the
warning if I try other themes. Can someone tell me what this warning

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]