[Fwd: Re: problem with pangox - and also with pkg-config !]

-------- Original Message --------
Subject: Re: problem with pangox - and also with pkg-config !
Date: Sun, 30 Nov 2003 05:00:10 +0100
From: busmanus <busmanus lk freemail hu>
To: Alain D'eurveilher <deurveia esiee fr>
References: <20031130014958 C020949BC6 mail esiee fr>

Alain D'eurveilher wrote:
 Hi all,

I'm trying to install GTK2.2.4 on my woody, and i already install the
demendencies requiered, and glib, atk, pango. Now, running ./configure
of gtk, I've got :
configure: error: pangox Pango backend is required for x11 target

Did if find the rest of Pango otherwise?

% pkg-config --list-all
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gtk+-2.0', required by 'gnome-window-settings-2.0', not found
ok, I'm trying to install gtk2.2.4, and i don't have the 2.0 verison.

gtk2.2.4 also belongs to the 2.0 line and it has its own gtk+-2.0.pc
file, but it will only be installed as a part of the package so don't
worry about that.

And where could I find the PKG_CONFIG_PATH ???

PKG_CONFIG_PATH can be either in either /usr/lib/pkgconfig
/usr/local/lib/pkgconfig etc., in short, it is a subdirectory in one or
more of the lib/ directories on your system, at least if your have the
corresponding files installed.
You can add its value on the command line when you run configure like

PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig ./configure

Miert fizetsz az internetert? Korlatlan, ingyenes internet hozzaferes a FreeStarttol.
Probald ki most! http://www.freestart.hu

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]